1. Hallo alle zusammen,
    dieser FAQ Bereich ist wie ja alle wissen lediglich für FAQs / Anleitungen gedacht. In diesen Themen darf jedoch diskutiert werden.
    Jedes Thema was hier eröffnet wird, muss aber mit einer FAQ / Anleitung beginnen. Leider landen hier von Neulingen viele Themen, welche nur Fragen beinhalten. Diese Themen haben hier natürlich nichts verloren und werden entsprechend von den Moderatoren in den Frage und Antwort Bereich verschoben.

    Damit wir uns zukünftig unnötige Arbeit sparen, haben wir folgendes geändert:
    1) Normale Mitglieder und Gäste dürfen hier im FAQ Bereich nur noch auf vorhandene Themen antworten. Sie dürfen hier keine Themen mehr erstellen. Die Forensoftware wurde so konfiguriert, dass Gäste und normale Mitglieder keine Themen im FAQ Bereich mehr eröffnen können. (es erscheint eine Fehlermeldung)

    2) Mitglieder, die eine FAQ / Anleitungen posten wollen, müssen in die Gruppe "FAQ" aufgenommen werden. Mitglieder in dieser Gruppe haben das Recht im FAQ Bereich Themen zu erstellen. Die Freischaltung erfolgt manuell von uns bzw. konkret von @pefo und @win7expert

    Frage: Wie bewerbe ich mich für die Gruppe "FAQ"? Antwort: Schreibt eine Nachricht an @pefo mit eurer Bewerbung, er wird euch dann ggf. freischalten. Wir freuen uns über Bewerbungen! :) Viele Grüße Euer Windows-7-Forum.net Team
    Information ausblenden

Windows in einen Wartungsmodus versetzen.

Diskutiere Windows in einen Wartungsmodus versetzen. im Windows 7 FAQ Forum im Bereich Windows 7; Naja, dennoch müsste die Wartung.cmd gestartet werden, schließlich ist sie ja auch durchgelaufen, als ich sie manuell gestartet habe, nur dass...

  1. #61 Sidewalksurfer, 20.01.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Naja, dennoch müsste die Wartung.cmd gestartet werden, schließlich ist sie ja auch durchgelaufen, als ich sie manuell gestartet habe, nur dass eben die Befehle vor denen ein time /t stand wohl nicht ausgeführt wurden.

    Woran könnte es also liegen, dass die Wartung nicht automatisch gestartet wird? Ich nehme mal an, dass liegt eben gerade an der Zeile, die ich in der Reinigung.cmd geändert habe. Aber wie bekomme ich das so hin dass es klappt?

    Gruß, Mitsch
     
  2. #62 Xwin7userX, 20.01.2013
    Xwin7userX

    Xwin7userX Erfahrener Benutzer

    Dabei seit:
    24.10.2010
    Beiträge:
    2.347
    Zustimmungen:
    0
    Version:
    Windows 7 Professional 64bit, ArchLinux 64bit
    System:
    siehe Signatur
    Du könntest mal probieren das Wartung.cmd >> Wartungslog.txt in eine zusätzliche Batchdatei zu schreiben und die dann in der Registry einzutragen. Näheres kann ich erst sagen, wenn ich morgen abend wieder an meinen Pc komme.
     
  3. #63 Sidewalksurfer, 20.01.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Das geht leider wieder weit über meine Möglichkeiten hinaus.
    Grundsätzlich liegt es aber wohl scheinbar an jenem veränderten Befehl in der Reinigung.cmd, oder? Oder könnte es doch auch etwas anderes sein?

    Ich habe mir auch schon folgendes überlegt:
    Ich könnte doch in der Reinigungsbatch die Befehle, welche für eine automatische Ausführung des Wartungsbatches sorgen (also jene in Zeile 10 und 15) rauskommentieren (mit einem REM versehen). Folglich müsste ich im Wartungsbatch ebenfalls die Zeilen 8 und 12 rauskommentieren.
    Dann würde ich als Administrator die Reinigung.cmd starten (nur durch Eingabe von "Reinigung.cmd").
    Im abgesicherten Modus könnte ich ja dann die Wartung manuell anstoßen und zwar durch "Wartung.cmd > Wartungslog.txt". Im abgesicherten Modus ist man ja eh schnell, die Zeit würde ich in jedem Fall davor sitzen bleiben können. Natürlich würden dann auch -sofern es so funktioniert- nur die Wartungsoperationen protokolliert, aber mir geht es eh nur um die.
    --> Könnte es so funktionieren???

    Gruß, Mitsch
     
  4. #64 Xwin7userX, 21.01.2013
    Xwin7userX

    Xwin7userX Erfahrener Benutzer

    Dabei seit:
    24.10.2010
    Beiträge:
    2.347
    Zustimmungen:
    0
    Version:
    Windows 7 Professional 64bit, ArchLinux 64bit
    System:
    siehe Signatur
    Ja, es liegt wohl an der veränderten Zeile in der Reinigung.cmd. Ich hab jetzt noch mal ein bisschen gegooglet und bin auf folgendes gestoßen, um die Ausgabe aller Befehle in der Batch Datei selber umzuleiten. Dazu fügst Du ganz oben in die Wartung.cmd folgendes ein:
    "%~F0" %* >> "C:\Wartungslog.log" 2>&1
    das 2>&1 bewirkt, dass außer stdout auch stderr umgeleitet wird, somit wird auf jeden Fall alles mit protokolliert.
    Dann machst Du in der Reinigung.cmd das ">> Wartungslog.log" wieder weg und es sollte funktionieren.
    Deine Variante sollte aber prinzipiell auch möglich sein, wenn auch vielleicht nicht ganz so komfortabel.
     
  5. #65 Sidewalksurfer, 02.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Hallo zusammen!

    Habe gerade meine nach den Anweisungen von Xwin7userX veränderte Wartung (siehe unten eingefügter Code) gestartet. Leider ist wieder etwas aufgetreten, was mich irritiert:
    Ich beschreibe zuerst mal wie ich vorgegangen bin:
    Ich habe
    1. Im Benutzerkonto die Eingabeaufforderung als Administrator ausgeführt
    2. Im Shell "Reinigung.cmd" eingegeben
    3. Im Fenster der Datenträgerbereinigung die entsprechenden Häckchen gesetzt und bestätigt.
    Dann lief eine Aktion der Datenträgerbereinigung durch. Das nächste erfassbare war das Herunterfahren von Windows. Anschließend wurde der abgesicherte Modus gestartet.
    4. Ich habe mein Benutzerkonto angeklickt
    Ich wurde angemeldet (Passwort hatte ich zuvor deaktiviert).
    Nun erschien ein schwarzer Bildschirm, in jeder Ecke steht "Abgesicherter Modus" und am oberen Bildschirmrand zentriert "Microsoft (R) Windows (R) (Build 7601: Service Pack 1).
    Ansonsten passiert(e) gar nichts, weder hat sich das Desktop oder nur die Startleiste aufgebaut, noch hat sich eine Shell geöffnet (was ich eigentlich erwartet hatte).

    areiland hat ja in den Wartungsbatch geschrieben, dass es so aussehen kann, als ob nichts mehr passiert, aber ich ging davon aus, dass zumindest eine Shell aufgehn müsste, in der eben genau die Befehle der Wartung und areilands Kommentare zu sehen sind, nur eben die Ausführung der Befehle lange dauern kann...

    Nun wüsste ich gerne, ob alles so ist, wie es sein sollte, oder ob wieder etwas aufgrund meiner Veränderung der Batches hakt.
    Falls letzteres der Fall ist, wäre ich super dankbar, wenn jemand mal in meinen Batches schauen könnte, wo der Fehler steckt. Die Batches findet ihr direkt im folgenden. Außerdem wäre es mir ein großes Anliegen, zu wissen was ich dann jetzt tun soll/muss, um aus dem abgesicherten Modus so herauszukommen, dass z.B. die Auslagerungsdatei wieder angeschaltet wird oder was eben sonst noch getan werden muss, damit alles wieder "normal" läuft.

    Code:
    @echo Reinigung.cmd
    @echo Startet die Datentraegerbereinigung mit den maximalen Optionen!
    @echo Im Fenster der Datentraegerbereinigung alle Punkte in der 
    @echo Liste anhaken und mit OK bestaetigen:
    cleanmgr /sageset:65535 & cleanmgr /sagerun:65535
    @echo.
    @echo.
    @echo Setzt den abgesicherten Modus mit Eingabeaufforderung:
    bcdedit /set safeboot minimal
    bcdedit /set safebootalternateshell yes
    @echo.
    @echo.
    @echo Setzt die Shell für den abgesicherten Modus mit Eingabeaufforderung so, 
    @echo dass der Wartungsbatch automatisch ausgefuehrt wird:
    REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot" /v AlternateShell /t REG_SZ /d "wartung.cmd" /f
    @echo.
    @echo.
    @echo Deaktiviert den Ruhezustand:
    powercfg -h off
    @echo.
    @echo.
    @echo Schaltet die Auslagerungsdatei ab:
    REG DELETE "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v PagingFiles /f
    @echo.
    @echo.
    @echo Startet den Rechner in den zuvor aktivierten abgesicherten Modus, in dem dann der Wartungsbatch ausgefuehrt wird:
    shutdown /r /t 0
    


    Code:
    @echo Wartung.cmd
    @echo Achtung: Diese Wartungsoperationen koennen einige Zeit in Anspruch nehmen!
    @echo Den Rechner nicht abschalten - auch wenn er scheinbar nichts mehr tut.
    @echo.
    @echo.
    @echo Befehl zur Ersellung einer Logdatei
    "%~F0" %* >> "C\:Wartungslog.log" 2>&1
    @echo.
    @echo.
    @echo Entfernt den Abgesicherten Modus mit Eingabeaufforderung und setzt den normalen Start:
    bcdedit /deletevalue safeboot
    bcdedit /deletevalue safebootalternateshell
    @echo.
    @echo.
    @echo Setzt die originale Einstellung für AlternateShell:
    REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot" /v AlternateShell /t REG_SZ /d "cmd.exe" /f
    @echo.
    @echo.
    @echo Setzt die Auslagerungsdatei wieder auf Verwaltung durch das System:
    REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management" /v PagingFiles /t REG_MULTI_SZ /d "c:\pagefile.sys 0 0" /f
    @echo.
    @echo.
    @echo Setzt einen Dateisystemcheck in Gang, der beim Neustart durchgefuehrt wird:
    time /t
    echo j | chkdsk /f
    @echo.
    @echo.
    @echo Loescht die gespeicherten Patches aus C:\Windows\Installer:
    time /t
    del /f /s c:\windows\installer\*.msp
    @echo.
    @echo.
    @echo Entfernt das Verzeichnis $PatchCache$ aus C:\Windows\Installer:
    time /t
    rd /s /q c:\windows\installer\$patchcache$
    @echo.
    @echo.
    @echo Loescht die Precompiled Inf Files (*.pnf) aus C:\Windows\Inf und seinen Unterverzeichnissen:
    time /t
    del /f /s c:\windows\inf\*.pnf
    @echo.
    @echo.
    @echo Fuehrt einen Systemdateicheck durch:
    time /t
    sfc /scannow
    @echo.
    @echo.
    @echo Defragmentiert die Festplatte:
    time /t
    defrag /c /u /v /x
    @echo.
    @echo.
    @echo Aktiviert den Ruhezustand:
    time /t
    powercfg -h on
    @echo.
    @echo.
    @echo Fuegt der Registry den Befehl zum Herunterfahren des Rechners 1 Minute nach dem Neustart zu,
    @echo der Befehl wird nur einmal ausgeführt um den Rechner abzuschalten, wenn alle Punkte abgearbeitet wurden:
    REG ADD "HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce" /v Shutdown /t REG_SZ /d "shutdown /s /t 60" /f
    @echo.
    @echo.
    @echo Startet den Rechner neu:
    shutdown /r /t 0
    
    Tausend Dank schon mal für die Hilfe!
    Grüße, Mitsch
     
  6. #66 daen, 02.02.2013
    Zuletzt bearbeitet: 02.02.2013
    daen

    daen Erfahrener Benutzer

    Dabei seit:
    25.10.2009
    Beiträge:
    4.018
    Zustimmungen:
    73
    Version:
    Win 7 64Bit Prof.
    System:
    Siehe Signatur.
    Also ich habe die Wartungsbatch in soweit geändert das ich vor den Befehlen chkdsk /f - sfc /scannow - und defrag -
    erstmal ein REM gefolgt von Leerstelle, davor gesetzt habe.
    Denn die Abarbeitung dieser 3 Schritte, das dauert schon ne ganze Zeit (bei ne 2TB Platte kanns schon 2 Stündchen dauern) und die müssen nicht jedesmal mit durchlaufen.( 1x im Monat reicht). Diese Schritte mache ich zwischendurch Manuell.
    Rest sieht ja soweit OK aus.
    Da ich anwesend bleibe, so habe ich den 60 sek. shutdown Befehl rausgenommen und lasse das System danach sofort wieder Neustarten.
     
  7. #67 Xwin7userX, 02.02.2013
    Xwin7userX

    Xwin7userX Erfahrener Benutzer

    Dabei seit:
    24.10.2010
    Beiträge:
    2.347
    Zustimmungen:
    0
    Version:
    Windows 7 Professional 64bit, ArchLinux 64bit
    System:
    siehe Signatur
    In der Wartung.cmd ganz oben ist ein Fehler. Es heißt nicht C\:Wartungslog.log sondern C:\Wartungslog.txt. Außerdem ist es normal, dass Du in der Shell nichts siehst, denn die komplette Ausgabe wird in die Log datei umgeleitet. Somit steht dabei alles in der Log Datei aber nichts in der Konsole. Es ist also normal, wenn Du einfach nur "schwarz" siehst ;)
    Wenn Du dieses Verhalten ändern willst, aber trotzdem die Ausgabe der Programme in der Datei haben willst, wird es etwas komplizierter. Evtl. könntest Du eine andere Shell öffnen, in der im Sekunden Takt der Inhalt der Logdatei angezeigt wird.
     
  8. #68 areiland, 02.02.2013
    areiland

    areiland Erfahrener Benutzer

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    @Sidewalksurfer
    Dir wurde doch die richtige Antwort gegeben! Du hast in der Befehlszeile ""%~F0" %* >> "C\:Wartungslog.log" 2>&1" genau an der markierten Stelle einen Fehler drin. Die beiden Zeichen müssen gegeneinander vertauscht werden - es muss also ""%~F0" %* >> "C:\Wartungslog.log" 2>&1" heissen. So wie es im Moment aussieht, bricht die Abarbeitung und damit auch die Eingabeaufforderung sofort ab wenn Cmd an diese Stelle kommt und den Syntaxfehler bemerkt.
     
  9. #69 Sidewalksurfer, 02.02.2013
    Zuletzt von einem Moderator bearbeitet: 03.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Erstmal DANKE für die schnellen Antworten.

    @Xwin7userX
    Ist es nicht egal, ob ich da ein .log oder ein .txt nehme? Schließlich hab ich das vorher nirgends "definiert", oder?
    Also ich sehe eigentlich gar keine Shell, das ist eigentlich mein Problem... oder ist dieser (fast) schwarze Bildschirm eben gerade meine leere Shell (wundert mich deshalb, weil im abgesicherten Modus der Desktop-Hintergrund genau so aussieht, wie das, was ich gerade auf der Mattscheibe habe...)?

    Gruß, Mitsch

    Oh, ich hab vor lauter Beachtung der Dateiendung gar nicht den Vertauschungsfehler gesehen. Danke, dass du das nochmal hervorgehoben hast Alex!

    Was mache ich nun um wieder in mein normales Windows zu kommen?

    Gruß, Mitsch
     
  10. #70 Sidewalksurfer, 02.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Ich bin mir nicht ganz sicher, aber nach dem Post von Alex (#68) müsste ich doch dann zumindest einige der Befehle manuell abarbeiten, um wieder "an mein normales Windows zu kommen".

    Ich habe mal ein bisschen rumprobiert und stelle mir das ganze jetzt so vor:
    Ich starte den Taskmanager und wähle "Datei" -> "Neuer Task" und gebe dann in dem Fenster, welches geöffnet wurde cmd ein und setze einen Haken in dem Kästchen "Diese Aufgabe mit Administratorrechten erstellen".
    Ich denke, dass dann die Eingabeaufforderung gestartet werden müsste, richtig?
    Dort würde ich dann nacheinander eingeben:

    bcdedit /deletevalue safeboot

    bcdedit /deletevalue safebootalternateshell

    REG ADD "HKLM\SYSTEM\CurrentControlSet\Control\SafeBoot" /v AlternateShell /t REG_SZ /d "cmd.exe" /f

    powercfg -h on

    shutdown /r /t 0

    (Das sind die meiner Ansicht nach zwingend notwendigen Befehle, um Windows wieder normal zu starten, bin mir aber absolut nicht sicher)


    Kann ich so verfahren?

    Gruß, Mitsch
     
  11. #71 Xwin7userX, 02.02.2013
    Xwin7userX

    Xwin7userX Erfahrener Benutzer

    Dabei seit:
    24.10.2010
    Beiträge:
    2.347
    Zustimmungen:
    0
    Version:
    Windows 7 Professional 64bit, ArchLinux 64bit
    System:
    siehe Signatur
    Die Befehle stehen doch schon in der Wartung.cmd, warum willst Du die dann nochmal neu ausführen?
    Die Dateiendung hab ich übrigens unabsichtlich geändert, eigentlich wollte ich nur auf den gleichen Fehler wie Alex aufmerksam machen.
     
  12. #72 areiland, 02.02.2013
    areiland

    areiland Erfahrener Benutzer

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Ja solltest Du! Eigene Befehle übrigens immer nach diesen Sequenzen einsetzen um deren Abarbeitung sicherzustellen.
     
  13. #73 Sidewalksurfer, 02.02.2013
    Zuletzt bearbeitet: 03.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    @Alex:
    Meinst du mit deiner Antwort ("Ja soltest du"), dass ich so verfahren soll?
    Mir ist nicht ganz klar, was du mit "nach diesen Sequenzen einsetzen" meinst. Verstehe ich es richtig, dass du nochmal darauf hinweisen wolltest, dass man die Befehle nicht alle auf einmal eingibt, sondern nach der Eingabe jedes einzelnen Befehls (bei mir eine Zeile) die Enter-Taste drückt und den Befehl ausführen lässt?

    Hast du auch überprüft, ob die von mir aufgeführten Befehle ausreichen?

    Dank und Gruß, Mitsch


    Es hat jetzt mit der manuellen Befehlseingabe geklappt.
    Allerdings wurde der Befehl zum Aktivieren des Ruhezustands nicht umgesetzt, es kam eine Meldung, dass Windows den Ruhezustand wieder deaktiviert hat. Ich nehme mal an, dass das irgendwie damit zusammenhängt, dass bei mir der Ruhezustand in irgend einer Form "auf der SSD gespeichert wird", kann das sein? Dann müsste ich die beiden Befehle für den Ruhezustand doch rauskommentieren können, oder?

    Ich habe nun den Fehler im Batch verbessert und die Reinigung gestartet. Nun hat sich nach dem Neustart im abgesicherten Modus -im Gegensatz zu vorher- eine Konsole geöffnet in der alles zu lesen ist, bis inklusive ""%~F0" %* >> "C\:Wartungslog.log" 2>&1" allerdings wird der Befehl in der Konsole nur als "1>> "C\:Wartungslog.log" 2>&1" ausgegeben.



    Die Wartung läuft jetzt seit fast drei Stunden. Kann es sein, dass wieder irgend etwas nicht stimmt? (Ich frage, weil ja insbesondere der Befehl den ich eingebaut habe in der Konsole nicht so ausgegeben wird, wie er in der Batch steht.)

    Wichtig: Gibt es eine Möglichkeit den Batch/die Ausführung der Befehle manuell zu stoppen? Ich möchte den Laptop ungern die ganze Nacht am Strom hängen haben, da der Akku nicht ausgebaut werden kann. Ohne Strom übersteht er die Nacht aber auch nicht. Ich würde also gerne das Abbarbeiten der Befehle abbrechen, um dann die Befehle die ich in Post #71 schon genannt habe manuell durchzuführen (um wieder ins "normale" Windows zu gelangen und dann den Laptop auszuschalten). Weiß jemand ob und wie das gehen könnte?



    mein Problem besteht immer noch, ich fasse der Übersichtlichkeit nochmal zusammen, wäre sehr, sehr dankbar für Hilfe.

    Ich habe die Reinigung.cmd gestartet und alles lief so wie es sollte, bis ich im abgesicherten Modus die Ausgabe "1>> "C\:Wartungslog.log" 2>&1" in der Konsole erhalten habe. Diese ergibt sich durch den Befehl ""%~F0" %* >> "C\:Wartungslog.log" 2>&1" aus der Wartungsbatch. Mich wunderte, dass der Befehl aus der Batch nicht mit der Ausgabe in der Konsole übereinstimmte.
    Seither - ca. 7,5 Stunden später - hat sich auf der graphischen Oberfläche nichts getan. Ich kann auch keine Eingaben in der Konsole mehr machen.

    Ich habe keine Ahnung was ich nun tun kann/muss, bin mir aber recht sicher, dass bei meiner Batch wieder irgend etwas nicht richtig ist und die Wartung nicht läuft.
    Kann mir jemand sagen, wie ich nun den abgesicherten Modus beenden und den Bootvorgang wieder auf ganz normal setzen kann?
    Außerdem wüsste ich wirklich zu gern, wo sich nun wieder ein Fehler eingeschlichen hat?

    Grüße, Mitsch
     
  14. #74 areiland, 03.02.2013
    areiland

    areiland Erfahrener Benutzer

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Die Ausführung eines jeden Batches kann man mit STRG+C abbrechen und dann kannst Du die oben schon genannten Befehle nutzen um die vorige Situation wiederherzustellen. Du bist übrigens der Einzige, der solche Probleme hat mit den Batches zurecht zu kommen.

    Eventuell solltest Du ja auch einfach mal Deine eigenen Zusätze auskommentieren (REM vor die Befehlszeile) und dann das Ganze laufen lassen. Dann siehst Du ja ob es an Deinen eigenen Befehlen liegt, die die Ausführung des Batches unterbrechen. Ich verstehe ohnehin nicht, warum Du die Abarbeitung der einzelnen Befehle mit Time-Angaben verzögern willst. Jede Befehlszeile wird immer erst dann ausgeführt, wenn die vorige Zeile durchlaufen wurde.
     
  15. #75 Sidewalksurfer, 03.02.2013
    Zuletzt bearbeitet: 03.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Danke für die Antwort!
    Ich hatte den "Befehl" STRG+C schon ergoogelt, da du aber in der Batch in den Kommentaren davor warnst, den PC abzuschalten, dachte ich dass auch das Beenden der Batch durch einen solchen Abbruchbefehl evtl. zu Problemen führen könnte, aber da hab ich wohl mal wieder falsche Schlüsse gezogen, sorry.
    Die Zeitangaben habe ich deshalb eingebaut (auf Hinweis von Xwin7userX), weil ich wissen wollte, wie lange welche Aktion bei meinem PC so braucht, um zu wissen, wie lange in der Regel die Wartung dauert. Ich dachte auch, dass es nicht arg lange dauern kann, die Zeit abzufragen, deshalb hab ich das einfach mal großzügig eingesetzt, aber da scheint ja doch mehr zu passieren.

    Wie würdest du denn die Erstellung einer Protokolldatei einbauen, in der zusätzlich noch zu erkennen ist, wie lange die Wartung.cmd läuft?

    Nochmals ganz vielen Dank!
    Gruß, Mischa
     
  16. #76 areiland, 03.02.2013
    areiland

    areiland Erfahrener Benutzer

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Dann setz Dich Doch einfach mal hin und füge nach jedem Befehl ein Pause ein, was Dich jedesmal zu einem Tastendruck zwingt wenn eine Befehlszeile durchlaufen ist. Ausserdem beobachte mal die Ausführung. Schon siehst Du was wann passiert. Meine Lösung ist darauf aufgebaut - dass man sie anschiebt, wenn man den Rechner ohnehin nicht mehr benötigt und dann eine Wartung durchführt - die letztlich darin gipfelt den Rechner geordnet abzuschalten. Also etwa an einem Freitagabend, an dem man die Reinigung anschiebt, das Ganze durchläuft und der Rechner hinterher abgeschaltet wird.

    Ich hab hier nur eine einfache und sehr effektive Möglichkeit aufgezeigt, wie man den Rechner mit Bordmitteln aufräumen kann - wenn man das will.
     
  17. #77 Sidewalksurfer, 03.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Ich hatte ja schon gelesen, wie du dir den Einsatzzweck der Batches vorstellst und fand das auch gut. Ich wollte aber eben wissen, ob ich dazu das Laptop an die Steckdose hängen muss (weil die Wartungdauer größer ist, als die Akkulaufzeit). In diesem Fall hätte ich die Wartung dann eben nur in meinen kurzen Nächten laufen lassen.

    Außerdem wüsste ich eben auch immer gern, ob irgendwo Fehler aufgetreten sind, oder z.B. wie fragmentiert die Festplatte war und ob sie vollständig defragmentiert werden konnte. Daher mein Wunsch nach einer Protokolldatei....

    Gruß, Mitsch
     
  18. #78 areiland, 03.02.2013
    areiland

    areiland Erfahrener Benutzer

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Fehler werden doch ohnehin in den Systemlogs protokolliert. Bei allen grösseren Aktionen sollte man das Netzteil am Laptop lassen. Meine Lösung hat doch gar nicht den Anspruch, dass sämtliche Details geloggt werden, sondern dass einfach eine Wartung des Rechners durchgeführt wird. Sozusagen - ohne Wenn und Aber - aber genau das war immer mein Ansinnen.

    Diese Zeile: "%~F0" %* >> "C:\Temp\Wartungslog.log" 2>&1 ist das Problem, wie ich herausgefunden hab.
     
  19. #79 daen, 03.02.2013
    Zuletzt von einem Moderator bearbeitet: 03.02.2013
    daen

    daen Erfahrener Benutzer

    Dabei seit:
    25.10.2009
    Beiträge:
    4.018
    Zustimmungen:
    73
    Version:
    Win 7 64Bit Prof.
    System:
    Siehe Signatur.
    @ Areiland
    Ich bedanke mich recht herzlich für deine Ausgiebige Arbeit.
    Die Ausführung deiner Batches, ist für mich ne reine Vertrauenssache.
    (habe nach wie vor wenig Ahnung davon)
    Mann kann es nicht jedem Recht machen. Wenn jemand meint, er müsse jeden Schritt kontrollieren der da Abläuft,
    (es sind ja Windows eigene Mitteln und keine Fremdsoftware), dann könnte mann doch jeden Befehl einzeln im cmd~shell (oder wie das heißt) eingeben und sieht was geschiet, dabei sitzt derjenige halt mal 3-4 Stunden vorm Rechner.
    Die Batches, für mich als Laie, ne klare Erleichterung. Danke für die Mühe.

    Deine DREHER sind immer noch vorhanden.....Besser C:\
     
  20. #80 Sidewalksurfer, 03.02.2013
    Sidewalksurfer

    Sidewalksurfer Erfahrener Benutzer

    Dabei seit:
    15.12.2012
    Beiträge:
    121
    Zustimmungen:
    0
    Version:
    Windows 7 Home Premium
    System:
    Lenovo U310; Intel-i5 @2x1,7Ghz mit Intel HD 4000 Grafik on Board; 4GB RAM; 500 GB HDD + 32 GB SSD
    Den Dreher hab ich aus Versehen beim hier eintippen wieder reingebracht, im Batch ist es richtig. Wie Alex ja geschrieben hat liegt das Problem an dem Befehl den ich wegen der gewünschten Protokolierung eingefügt hab.

    Ich hab es jetzt so hingenommen, dass das mit der Protokollierung nicht einfach genug (für mich) hinzubekommen ist. Um meinen Akku zu schonen werd ich die Wartung eben immer laufen lassen, während ich nicht am Laptop, aber am Schreibtisch, arbeite. Dann kann ich ihn einstecken, wenn es nötig wird.

    Ich bin Alex auch sehr dankbar, zum einen dafür, dass er mich davor bewahrt hat, meinem System mit Tuningsoftware zu schaden, zum anderen für die Bereitstellung der Batches und die Hilfe im Umgang damit. Natürlich bin ich auch all den anderen Helfern hier dankbar. Ich hatte eben einfach gehofft, dass es leichter wäre die Batches nach meinen Wünschen anzupassen.


    Gruß, Mitsch
     
Thema: Windows in einen Wartungsmodus versetzen.
Besucher kamen mit folgenden Suchen
  1. wie lange dauert die wartung bei windows 8

    ,
  2. windows 8 abgesicherter modus eingabeaufforderung

    ,
  3. wie lange dauert windows wartung

    ,
  4. windows 7 wartungsmodus,
  5. wie lange dauert eine wartung bei windows 8,
  6. windows 8 automatische wartung dauer,
  7. wie lange dauert automatische wartung windows 8,
  8. win 8 wartung wird durchgeführt,
  9. windows 8 automatische wartung,
  10. windows 8 wie lange dauert wartung,
  11. cmd befehl neustart abgesicherten modus win 7,
  12. win 7 abgesicherter modus,
  13. batchdatei für windows 8 abgesicherter modus,
  14. windows 7 Wartung Reinigung cmd Script ,
  15. windows 8 wartung dauer,
  16. cmd abgesicherter modus win7,
  17. windows 8 automatische wartung herunterfahren,
  18. wie lange dauert wartung bei windows 8,
  19. windows 8 wartung wird durchgeführt,
  20. windows 8 automatische wartung dauert stunden,
  21. windows 8 wie lange dauert eine wartung,
  22. windows 8 wartung wird durchgeführt dauer,
  23. windows 8 wartung dauert lange,
  24. win7 wartungsmodus,
  25. wie lange dauert eine windows wartung
Die Seite wird geladen...

Windows in einen Wartungsmodus versetzen. - Ähnliche Themen

  1. Windows Explorer: Es gibt zwei Ordner für Dokumente; was ist der Unterschied?

    Windows Explorer: Es gibt zwei Ordner für Dokumente; was ist der Unterschied?: Im Explorer gibt es zwei Ordner für Dokumente: a) Im Ordner "Bibliotheken" den Ordner "Dokumente" b) Im Ordner mit dem Benutzernamen den Ordner...
  2. [Windows 7] begrenzte Bandbreite mit WLAN-Adapter Asus Wireless-N150

    [Windows 7] begrenzte Bandbreite mit WLAN-Adapter Asus Wireless-N150: Guten Tag, ich habe mir vor kurzem eine neue Hardware gekauft, weil ich Probleme mit meiner alten hatte. Es geht um das gleiche Produkt und zwar...
  3. Windows 7 ruckelt

    Windows 7 ruckelt: Hallo liebe Community, ich bin neu hier und hoffe mir kann jemand weiter helfen da ich langsam wirklich ratlos bin [IMG] Und zwar ist mein...
  4. Von Windows 7 32bit auf Windows 7 64bit upgraden

    Von Windows 7 32bit auf Windows 7 64bit upgraden: Hallo, wie der titel schon sagt, möchte ich meinen 8gb ram toshiba läppi von win7 32bit auf 64bit upgraden. ist schon klar, das eine vollständige...
  5. Unerwartete Updates von Windows 7 - Malware/Virus?

    Unerwartete Updates von Windows 7 - Malware/Virus?: Hallo, ich bin neu hier, bitte um Nachsicht, wenn ich etwas falsch mache. Ich habe wg. alter Software noch Win 7 in einer virtuellen Maschien...