Windows Explorer liest nicht die SD-Karte im "Generic SDXC/MMC USB Device"

Diskutiere Windows Explorer liest nicht die SD-Karte im "Generic SDXC/MMC USB Device" im Windows 7 Treiber & Hardware Forum im Bereich Windows 7; Hi zusammen, ich habe da ein sehr merkwürdiges Verhalten meines PC und finde keine Lösung. Zuerst die Fakten zum PC (Kaufdatum Okt. 2011). -...

  1. #1 guennie, 11.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Hi zusammen,
    ich habe da ein sehr merkwürdiges Verhalten meines PC und finde keine Lösung. Zuerst die Fakten zum PC (Kaufdatum Okt. 2011).
    - Asus P8Z68 DELUXE
    - Intel Core i7-2600K
    - 16 GB (4x4) RAM
    - Gainword GTX560Ti Phantom
    - Silverstone Fortress FT02B
    - OCZ Vertex3 maxIO 120 GB
    - Sony BD-5300S-0B
    - Windows 7 Professional 64Bit

    Habe im Februar einen DeLOCK 3,5" MultiPanel CardReader+USB nachgerüstet, um Fotos von div. Kameras über CompactFlash- und SDHC-Karten einzulesen. Gerät wird von Win7 erkannt und die zwei USB-Anschlüsse arbeiten einwandfrei. Im Windwos Explorer werden auch die vier Slots für Wechseldatenträger als Geräte G:, H:, I: und J: angezeigt.
    - Generic Compact Flash USB Device
    - Generic MS/MS-Pro/HG USB Device
    - Generic SDXC/MMC USB Device
    - Generic xD-Picture USB Device
    Wenn ich eine SD-Karte SanDisk Extreme Pro 8GB (oder eine CompactFlash SanDisk Extreme III 4 GB) einschiebe, tut sich erst einmal (fast) nichts. Lediglich links in der Verzeichnisansicht, taucht jetzt das verwendete Gerät auf, so als hätte Windows erkannt, dass das Gerät benutzt wird.
    Wenn ich jetzt darauf klicke, kommt "Bitte legen Sie einen Datenträger in das Gerät".
    Auch die Computerverwaltung/Datenträgerverwaltung erkennt, dass ein Datenträger eingelegt ist und teilt mit:
    7,40 GB RAW Fehlerfrei (Primäre Partition).
    Ich kann Windows partout nicht überreden, den Karteninhalt zu lesen.
    Wenn ich jetzt aber mit eingesteckter Karte Windows neu boote, erkennt der Explorer die Karte korrekt und ich kann den Inhalt auslesen.
    Microsofts FixIt! brachte keinen Erfolg. Jetzt hoffe ich auf Eure Kompetenz.
     
  2. #2 areiland, 11.07.2012
    areiland

    areiland Erfahrener Benutzer
    Moderator

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Starte eine Konsole mit Adminrechten (rechte Maustaste auf Cmd.exe und "Als Administrator ausführen"), dort führst Du folgende Befehle aus:

    diskpart
    automount disable
    automount scrub
    automount enable
    exit
    exit

    Wahrscheinlich hast Du in der Vergangenheit des öfteren USB Laufwerke angesteckt und die Liste der automatisch gemounteten Laufwerke ist voll, so dass Windows keine mehr automatisch mounten mag. Mit meinen Befehlen wird diese Liste bereinigt, so dass Windows wieder automatisch mountet.
     
  3. #3 guennie, 11.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Danke Alex,

    hat aber nicht geholfen. Habe exakt deine Befehle abgearbeitet. Dann vorsichtshalber rebootet. Immer noch der beschriebene Effekt.

    Gruß guennie
     
  4. #4 areiland, 11.07.2012
    areiland

    areiland Erfahrener Benutzer
    Moderator

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Formatiere die Karten über Windows, möglicherweise werden sie deswegen nicht richtig erkannt weil sie in der Kamera formatiert wurden.
     
  5. #5 guennie, 11.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Obwohl im Handbuch der Kamera steht, man solle die Karte mit der Kamera formatieren (Canon benutzt hier exFAT), habe ich deinen Tipp befolgt und die Karte mit dem Explorer auf exFAT formatiert. Natürlich hat FORMAT gemeckert, dass ein anderer Prozess die Karte benutzt, aber man kann ja trotzdem formatieren. Nach der Formatierung war die Karte auch sofort im Explorer als leer erkannt, ohne Aufforderung, einen Datenträger einzulegen. Habe sie dann entnommen, ein Bild gemacht und die SD-Karte wieder eingelegt. Keine Änderung, immer noch derselbe Effekt. Es ist zum Verzweifeln.
     
  6. #6 areiland, 11.07.2012
    areiland

    areiland Erfahrener Benutzer
    Moderator

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Genau bei exFat und der Kamera wird das Problem liegen. Möglicherweise verpasst die Kamera der Karte eine Signatur, die die Windows Signatur überschreibt.
     
  7. #7 guennie, 11.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Warum kann ich aber dann nach einem Reboot mit eingesteckter Karte diese ordnungsgemäß lesen? Außerdem hätten schon andere Canon-Besitzer aufgeschrien.
     
  8. #8 areiland, 11.07.2012
    areiland

    areiland Erfahrener Benutzer
    Moderator

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Vielleicht weil die meisten nicht den Weg über einen Kartenleser gehen sondern die Kamera als Laufwerk nutzen? Windows erkennt die Karte regelmässig mit keinem Dateisystem - deswegen die Angabe RAW. Das heisst immer dass Windows die Partitionsinformationen nicht lesen kann, also das Dateisystem unbekannt oder defekt ist.

    Eines fällt mir da noch ein, weil Du beim Formatieren den anderen Prozess erwähnt hast, bei erkannter Karte die Eigenschaften des Laufwerks aufrufen und Readyboost für die Karte deaktivieren. Könnte sein, dass der das Problem ist.
     
  9. #9 guennie, 14.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    ReadyBoost ist bei mir deaktiviert.
     
  10. #10 guennie, 14.07.2012
    Zuletzt bearbeitet: 14.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Also nochmal zum Thema Filesystem.
    Ich habe mal die SD-Karte mit Windows nach FAT32 formatiert. Der Explorer erkennt dann auch die Karte und dass sie leer ist. Danach habe ich über "Hardware sicher entfernen" die Karte herausgenommen und anschließend wieder hineingesteckt. Problem ist sofort wieder da, wenn ich darauf zugreifen will: Bitte legen Sie einen Datenträger ....:mad:

    Interessant ist, dass die Datenträgerverwaltung auch hier sagt "7,40 GB RAW".
    Damit weiß ich zumindest, dass mein Problem nichts mit der Kamera und nichts mit exFAT zu tun hat.

    Also: weitersuchen:confused:

    Nachtrag: Die Karte lässt sich über die rechte Maustaste auch formatieren, obwohl der Explorer den Inhalt nicht erkennt. Format meckert zwar noch, weil ein anderer Prozess ... Nach der Formatiereung wird die Karte sofort korrekt erkannt. Jetzt meint auch die Datenträgerverwaltung "7,40 GB exFAT".

    Wie kann ich feststellen, welcher Prozess sich die Karte krallt? Microsofts Prozess Monitor hilft mir nicht.
     
  11. #11 guennie, 16.07.2012
    guennie

    guennie Neuer Benutzer

    Dabei seit:
    22.08.2010
    Beiträge:
    17
    Zustimmungen:
    0
    Version:
    Win7 Prof 64Bit
    System:
    Asus P8Z68 DELUXE
    Gelöst: Windows Explorer liest nicht die SD-Karte im "Generic SDXC/MMC USB Device"

    Heureka!
    Bin über Microsofts Prozess Monitor drauf gekommen, dass ein Prozess mvraidsvc.exe sich die SD-Karte (oder auch andere Karten) krallt und nicht wieder loslässt. Der Prozess gehört zum Marvell Storage Utility (MSU), das mit dem ASUS Mainboard mitgeliefert wird. Ich habe zwar zwei HD an Marvells SATA6-Controller im RAID1-Array, aber das besagte Utility wird dazu nicht gebraucht, die Controller-Treiber reichen dazu aus. Also habe ich MSU über die Systemsteuerung deinstalliert, und siehe da, die SD-Karte wird sofort nach Einlegen erkannt. Das Ganze hat noch einen zweiten Vorteil: Die I/O-Aktivität ist erheblich zurückgegangen. :)
     
Thema: Windows Explorer liest nicht die SD-Karte im "Generic SDXC/MMC USB Device"
Besucher kamen mit folgenden Suchen
  1. win7 erkennt keine sdxc

    ,
  2. sandisk sdxc liest nicht mehr

    ,
  3. generic sd mmc usb device driver windows 7

    ,
  4. sdhc karte lesen 64 gbyte windows 7,
  5. generic_usb_sd_reader usb device,
  6. generic kartenleser treiber win7,
  7. explorer card reader nicht angezeigt,
  8. windows 7 kartenleser legen sie einen datenträger ein,
  9. Treiber für 8 in 2 OEI USB Compact Flash Windows 10,
  10. generic card reader mmc/sd usb device,
  11. was ist ein generic USB SD reader USB device,
  12. generic usb sd card reader driver,
  13. generic compact flash,
  14. generic 2.0 reader,
  15. boot device usb generic compact flash erklärung,
  16. pc erkennt sdxc karte nicht,
  17. Gerätebeschreibung Generic USB CF Reader USB Device,
  18. generic sl64G SD,
  19. generic compact flash usb device treiber download,
  20. generic usb sd reader microsoft 32gb,
  21. generic usb sd reader usb device treiber,
  22. generic usb 3.0 card reader driver,
  23. sdxcmmc mspro,
  24. generic-msms-pro,
  25. vista liest sd card nicht
Die Seite wird geladen...

Windows Explorer liest nicht die SD-Karte im "Generic SDXC/MMC USB Device" - Ähnliche Themen

  1. Wie zufireden seit ihr mit Windows 7?

    Wie zufireden seit ihr mit Windows 7?: Wurde gern eure Meinung hören wie gefällt euch der Windows 7?
  2. Welchen Antivirus Programm benutzt ihr auf Windows 7?

    Welchen Antivirus Programm benutzt ihr auf Windows 7?: Wie ihr sehen könnt, mich wurde mal interessieren welchen Antivirus Programm benutzt ihr auf euren Computer?
  3. Windows Office Home and Student 2013

    Windows Office Home and Student 2013: Hallo Zusammen, habe mal wieder ein Problem. Ob in Word oder Exel, wenn ich eine Datei ausdrucken will, stürzt diese jeweils ab. Meldung:...
  4. [Windows-7-XP-Mode; Exe]Kann Datei nicht installieren

    [Windows-7-XP-Mode; Exe]Kann Datei nicht installieren: Hallo, an anderer Stelle habe ich von meinem Treiber-Problem berichtet. Meine Idee war nun, dem Setup-Programm XP nicht nur vorzugaukeln, sondern...
  5. [Windows 7] Treiberinstallation scheitert am Setup-Programm von ASUS

    [Windows 7] Treiberinstallation scheitert am Setup-Programm von ASUS: Hallo, ich habe gebraucht ein älteres Mainboard von ASUS (A8R-MVP) gekauft, weil ich die PCI-Slots brauche. Neuere Boards haben die nicht, nur...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden