Neue Fenster immer im Vordergrund öffnen!

Diskutiere Neue Fenster immer im Vordergrund öffnen! im Windows 7 anpassen und individualisieren Forum im Bereich Windows 7 FAQ; Da diese Frage hier schon häufiger gestellt wurde und teilweise nicht zufriedenstellend beantwortet wurde, hier noch mal die Lösung, die ich mir...

  1. #1 pefo, 09.05.2010
    Zuletzt bearbeitet: 28.10.2010
    pefo

    pefo Erfahrener Benutzer
    Moderator

    Dabei seit:
    14.12.2009
    Beiträge:
    10.897
    Zustimmungen:
    1
    Version:
    W7 Enterprise x64
    System:
    AMD Phenom II X4 3,2 GHz - 8GB Ram - 8TB HD
    Da diese Frage hier schon häufiger gestellt wurde und teilweise nicht zufriedenstellend beantwortet wurde, hier noch mal die Lösung, die ich mir durch langes Googlen zusammengesucht habe.

    Jeder hat vielleicht schon mal eine vermeintlich hängengebliebene Installation auf seinem Rechner gehabt. Im Nachhinein entpuppte sich dann der "Fehler" als ein verdecktes Dialogfenster im Hintergrund, das nur auf einen Klick auf die Schaltfläche "OK" gewartet hat.
    Oder man steckt einen USB-Stick an, und das Auswahlfenster für die "Automatische Wiedergabe" versteckt sich auch irgendwo im Hintergrund. Nur das Explorer-Icon in der Taskleiste blink einen Moment lang um auf das Fenster aufmerksam zu machen. Das blinken hört dann aber nach einer gewissen Zeit auf.

    Dieses Verhalten kann über die Registrierungsdatenbank von Windows, korrigiert werden.

    So sorgt man dafür, dass das Dialogfenster sofort im Vordergrund gezeigt wird:

    1. Über Klick auf Start (oder WIN +<R>), in der Eingabezeile "regedit" eingeben
    2. Den Schlüssel "HKEY_CURRENT_USER\Control Panel\Desktop" suchen und anklicken.
    3. Im rechten Fenster auf den Eintrag "ForegroundLockTimeout" klicken den Wert "0" eintragen. (Dieser Wert gibt an, wie viele Millisekunden ein Fenster warten soll, bis es in den Vordergrund wechselt).
    4. Nun den Registrierungseditor schließen. Ab sofort werden alle Dialogfenster, die eine Eingabe anfordern, sofort in den Vordergrund geschickt.

    Tipp! Man kann das Dialogfenster auch durch ständiges Dauerblinken in der Taskleiste auf sich aufmerksam machen lassen. Dies kann so geändert werden:

    • Im gleichen Schlüssel, der zuvor geöffnet war, befindet sich im rechten Fenster der Eintrag "ForgroundFlashCount". Der Wert dieses Eintrags bestimmt, wie oft ein auf eine Eingabe wartendes Dialogfenster in der Taskleiste blinkt. Der Standard Wert ist "7".
    • Diesen Wert auf "0" setzen.
    • Nun wird das Blinken in der Taskleiste so lange fortgesetzt, bis man eine Schaltfläche betätigt oder das Fenster schließt.

    Somit gibt es zwei gute Methoden mit denen bestimmt werden kann, ob sich ein Dialogfenster, das auf eine Eingabe wartet, automatisch in den Vordergrund zwängt oder durch Dauerblinken in der Taskleiste auf sich aufmerksam macht.

    Viel Spass beim umsetzen... [​IMG]
    pefo
     
  2. #2 wkt, 09.05.2010
    Zuletzt bearbeitet: 06.10.2010
    wkt

    wkt Erfahrener Benutzer

    Dabei seit:
    01.01.2010
    Beiträge:
    450
    Zustimmungen:
    0
    Version:
    Win 7 HP 32Bit SP1, Upgrade Vista HP OEM, WinCE 6/7 Linux- Android auf wm8505/wm8650/, Linux Mint 17
    System:
    MSI G31M V2 (MS-7379) Intel Q6600 RAM 3GB HDD 500GB NVIDIA GeForce 8600 GS
    Danke für die Information : habe den Hack gleich durchgeführt.;););)

    NACHTRAG 06.10.2010 : habe keine Änderung im Verhalten festgestellt.
     
  3. Jenspb

    Jenspb Neuer Benutzer

    Dabei seit:
    13.04.2010
    Beiträge:
    12
    Zustimmungen:
    0
    Version:
    Enterprise 32Bit
    System:
    Core Core2Duo E6550 2,33 GHz 2gb Arbeitsspeicher OFFICE 2003 Onboard GraKa GMA3100 GK
    Hallo,

    ich habe das Problem mit Lotus Notes und dem Internet Explorer in Windows 7
    Öffne ich einen Hyperlink in LN z.b. auf einen IE Link, dann öffnet der IE im Hintergrund und in der Taskleiste ist machmal nichts zu sehen, manchmal blinkt der IE in der Taskleiste.

    Ich muss dann im Task Manager den IE Task doppelt anklicken und dann kommt der IE in den Vordergrund.

    Allerdings habe ich auch schon den Registry Wert "ForegroundLockTimeout" bereits auf "0" gesetzt; default = 20000.
    keine Änderung

    Es ist auch nicht so, dass das Fenster in der Taskleiste blinkt. Das tat es aber früher bei diversen Installationen, wo Dialoge im Hintergrund blieben und ich nur durch die blinkende Taskleiste darauf aufmerksam wurde.

    Weiß jemand eine Lösung????
     
  4. minira

    minira Neuer Benutzer

    Dabei seit:
    30.05.2010
    Beiträge:
    3
    Zustimmungen:
    0
    Version:
    Pro
    Hallo pefo,

    diese Änderung im regedit hat nichts gebracht.
    Das Fenster für den Drucker-Code wird ja nicht versteckt angezeigt, sondern man muss es in der Taskleiste erst anklicken, dann öffnet sich das Fenster, die Zahl wird eingetippt, mit Enter wird gedruckt.

    Der große Unterschied:
    Im gleichen System wird aus regedit direkt gedruckt, nach "Stg+p" erscheint auf dem Bildschirm im Vordergrund das Fenster für den Drucker-Code.
     
  5. #5 tender56, 21.01.2014
    tender56

    tender56 Neuer Benutzer

    Dabei seit:
    21.01.2014
    Beiträge:
    1
    Zustimmungen:
    0
    Version:
    Windows 8
    System:
    Intel 3.Gen. SSD+Festplatte
    Hallo,

    Der Beitrag ist zwar schon älter aber er hat mir geholfen.
    Ich hatte zuvor das selbe Problem (keine Auswirkung nach Registry-Änderung) und will diesen Eintrag ergänzen.

    -> Die Einträge in die Registry werden erst nach einem Neustart übernommen und wirksam.

    Zumindest bei mir hat ein Neustart geholfen.
     
  6. jotel

    jotel Neuer Benutzer

    Dabei seit:
    05.11.2009
    Beiträge:
    4
    Zustimmungen:
    0
    Version:
    Win 8.1 pro
    System:
    ASUS Laptop + ASUS Desk
    Danke schön: nach 5 Jahren, mit Windows 8.1 genauso wirkungsvoll!
    Tschüsschen.
     
  7. Anzeige

    Hi,
    Schau dir mal diesen Windows-Ratgeber an!
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema: Neue Fenster immer im Vordergrund öffnen!
Die Seite wird geladen...

Neue Fenster immer im Vordergrund öffnen! - Ähnliche Themen

  1. Nach einer Weile kann ich kein Programm mehr öffnen und muss neustarten

    Nach einer Weile kann ich kein Programm mehr öffnen und muss neustarten: Hi, ich hatte dieses Problem bereits bei meinem alten Rechner (Phenom II x4 BE) und seit 2 Tagen ist es jetzt auch auf meinem neuen PC. Ich bin...
  2. WIN 7 64 Bit Original CD/DVD jetzt auf MAC Book neu installieren - da aber nur ISO Win 10...

    WIN 7 64 Bit Original CD/DVD jetzt auf MAC Book neu installieren - da aber nur ISO Win 10...: Hallo, mittels älterer Original-CD/DVD möchte ich auf meinem neuen MAC Book mittels Boot Camp eine Win-Partition anlegen. Bootcamp sagt aber...
  3. Neue Zeiten ... leider sehr unfein!

    Neue Zeiten ... leider sehr unfein!: Kaum zu glauben, liest sich wie fake-news - ist es leider nicht :eek: (hat zwar nichts mit den eigentlichen Themen hier zu tun, aber "unter den...
  4. Ordner im Navigationsbereich nicht automatisch öffnen - nur da!

    Ordner im Navigationsbereich nicht automatisch öffnen - nur da!: Hallo Forum, über dieses Thema steht ja schon viel geschrieben, aber was ich meine, finde ich nicht. Wenn ich im Explorer im Navigationsfenster...
  5. Windows will immer USB-Stick formatieren

    Windows will immer USB-Stick formatieren: Wenn ich einen USB-Stick anschließe will Windows immer den Stck neu formatieren, auch wenn Daten drauf sind. Wie kann man den Automatismus abstellen?