autorun geht nicht

Diskutiere autorun geht nicht im Windows 7 Customizing Forum im Bereich Windows 7; Hallo, ich habe folgendes Problem: Seit einiger Zeit funktioniert mein Autorun für CDs nicht mehr. Immer wenn ich eine CD einlege sehe ich nur ein...

  1. #1 shell32, 12.08.2012
    shell32

    shell32 Benutzer

    Dabei seit:
    12.08.2012
    Beiträge:
    70
    Zustimmungen:
    0
    Version:
    Windows 8 x64
    System:
    Asrock 970 Extreme4 - FX-6100 4,0 Ghz - 8 GB RAM - 1 TB HDD - 32 GB Cache SSD - HD 6870
    Hallo, ich habe folgendes Problem:
    Seit einiger Zeit funktioniert mein Autorun für CDs nicht mehr.
    Immer wenn ich eine CD einlege sehe ich nur ein Menü mit dem Punkt Order öffnen und sowas wie "Bilder und Videos importieren".
    Ich habe schon den Haken bei automatische wiedergabe gesetzt und auch in der registry unter cdrom und policies/explorer geguckt.
    Aber es funktioniert immer noch nicht.
    Was soll ich tun? :(
     
  2. pefo

    pefo Erfahrener Benutzer

    Dabei seit:
    14.12.2009
    Beiträge:
    10.897
    Zustimmungen:
    2
    Version:
    W7 Enterprise x64
    System:
    AMD Phenom II X4 3,2 GHz - 8GB Ram - 8TB HD
    Welche Antivirensoftware benutzt Du?

    Viele Antiviren-Suiten verhindern inzwischen standardmäßig den Autostart von CD/DVD!
    Man erkennt es auch, wenn man versucht die Datei autorun.inf in einem Editor zu öffnen, da selbst dies, durch die Antivirensoftware verhindert wird!
     
  3. #3 shell32, 12.08.2012
    shell32

    shell32 Benutzer

    Dabei seit:
    12.08.2012
    Beiträge:
    70
    Zustimmungen:
    0
    Version:
    Windows 8 x64
    System:
    Asrock 970 Extreme4 - FX-6100 4,0 Ghz - 8 GB RAM - 1 TB HDD - 32 GB Cache SSD - HD 6870
    Ich benutze avast, aber ich hatte auch schon andere die vielleicht etwas gemacht haben.
    Allerdings kann ich die Dateien trotzdem öffnen.
     
  4. #4 areiland, 13.08.2012
    areiland

    areiland Erfahrener Benutzer
    Moderator

    Dabei seit:
    11.12.2009
    Beiträge:
    16.880
    Zustimmungen:
    2
    Version:
    Windows 10 Pro x64 Build 1511 10586.29
    System:
    970M Pro3, AMD FX6350, ATI 7730, 16GB DDR3 1600, SSD256 GB, HD502HJ, SH224BB
    Der Autorun wurde mit einem Update unterbunden! Es ist einfach ein zu grosses Einfallstor für Viren.
     
  5. #5 shell32, 13.08.2012
    shell32

    shell32 Benutzer

    Dabei seit:
    12.08.2012
    Beiträge:
    70
    Zustimmungen:
    0
    Version:
    Windows 8 x64
    System:
    Asrock 970 Extreme4 - FX-6100 4,0 Ghz - 8 GB RAM - 1 TB HDD - 32 GB Cache SSD - HD 6870
    Wieso gibt es dann den Punkt in der Registry?
     
  6. #6 cardisch, 13.08.2012
    cardisch

    cardisch Erfahrener Benutzer

    Dabei seit:
    08.07.2010
    Beiträge:
    6.202
    Zustimmungen:
    31
    Version:
    Ultimate 64
    System:
    MSI 975x, Core2Quad Q6700, 4 GB RAM, Samsung SSD830 System SSD, 2*2TB & 2*1TB-HDD, AMD HD4870
    Wo ?!
    Es gibt nämlich Userspezifische und maschinenspezifische Schlüssel...
    Und dass das unterbunden wird ist auch gut so...
    Es ist leider nur zu dämlich, dass das bei USB-Sticks nicht so konsequent ausgeführt/unterbunden wird.

    Gruß
     
  7. #7 shell32, 13.08.2012
    shell32

    shell32 Benutzer

    Dabei seit:
    12.08.2012
    Beiträge:
    70
    Zustimmungen:
    0
    Version:
    Windows 8 x64
    System:
    Asrock 970 Extreme4 - FX-6100 4,0 Ghz - 8 GB RAM - 1 TB HDD - 32 GB Cache SSD - HD 6870
    ja, natürlich gibt es leute die auf alles klicken was sich öffnet aber wenigstens bei cds sollte es noch funktionieren.
    es ist bei hkey_local_machine\system\current control set\services\cdrom.
    Da steht autorun.
     
  8. #8 weiswas, 01.02.2013
    weiswas

    weiswas Neuer Benutzer

    Dabei seit:
    12.10.2011
    Beiträge:
    11
    Zustimmungen:
    0
    Version:
    Win 7 Ultimate / WIN 8.1
    System:
    Fujitsu NB / STREACOM FC8 Evo Fanless
    Es geht schon, aber..:

    Problem mit Verhalten von Film-DVDs mit weiteren Inhalten (Bilder, etc.) oder Software-DVDs z.B. von Computerzeitschriften


    Problem: Auf der CD/DVD gibt es eine Datei "autorun.inf" in der der Pfad zum auszuführenden Programm hinterlegt ist, aber Windows liest diese Datei bei einigen PCs aus, bei anderen nicht.

    Wie in anderen Beiträgen beschrieben, sollte dies aus Sicherheitsgründen nicht automatisch geschehen, damit keine unbekannte (Schad-)Software installiert wird.

    Wer dem Absender vertraut und möchte, dass das Programm startet, kann es auf folgende Wege erreichen:

    Voraussetzungen und Tests:


    1. Gruppenrichtlinie gesetzt?

    Auf jedem Fall darf die Autoplay-Funktion in den Gruppenrichtlinien nicht für CD/DVD-Laufwerke deaktiviert sein. Obwohl diese Funktion in der -> Systemsteuerung -> "Automatische Wiedergabe" aktiviert wurde (Haken gesetzt bei "Automatische Wiedergabe für alle Medien und Geräte verwenden"), kann sie dort (Regkey) wieder für bestimmte Geräte deaktiviert werden.

    1.1 Prüfen ob die Richtlinie für ein Gerät/Device aktiviert ist (= Autoplay ist deaktiviert):

    Mit der rechten Maustaste im Explorer - bei eingelegter DVD - auf das Laufwerk klicken und das Kontextmenü öffnen. Hier sollten die Einträge:
    - "Erweiterte Inhalte anzeigen" (bei erweiterten/enhanced Audio/Video-DVDs) oder
    - "Programme installieren oder ausführen" (bei reinen Daten/Software-DVDs) erscheinen
    und zusätzlich auch "Automatische Wiedergabe öffnen" oder nur "Wiedergabe".

    Gibt es die Einträge, dann weiter mit 2., sonst:

    1.2 Deaktivieren der Richtlinie

    - Programm Regedit starten (Über -> Start -> im Feld [Programme/Dateien durchsuchen"] "regedit" eingeben)
    - Zum Schlüssel "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer" navigieren
    - Den DW-Wert "NoDriveTypeAutoRun" löschen, besser auf den Wert x91 = 145 setzen (blockiert dann weiterhin Netzlaufwerke und unbekannte angeschlossene Geräte). Genauere Erklärungen siehe hier:
    Windows 7 AutoPlay Enable Disable | NoDriveTypeAutoRun Registry Key

    - Jetzt über den Taskmanager die explorer.exe beenden und neu starten (Register Anwendungen -> Neuer Task..) oder PC neu starten.

    1.3 Prüfen, ob im Kontextmenü die obigen Einträge jetzt erscheinen
    .
    Falls nicht muss in der Registry der obige Wert unter: "HKEY_CURRENT_USER\Software\Microsoft\Windows \CurrentVersion\Policies\Explorer" ebenfalls noch gelöscht werden und PC rebooten.

    Hinweis:
    Win7 Pro User könnten den Gruppenrichtlinien-Editor verwenden (gpedit.msc). Dort ist der Eintrag im Abschnitt: "Computerkonfiguration -> Windows-Komponenten -> Richtlinien für die automatische Wiedergabe", Wert "Autoplay deaktivieren" zu finden.
    Leider kann er nicht auf den Wert x91(145) gesetzt werden, er müsste dann ganz gelöscht werden. Weitere Werte sind nur:
    "Alle Laufwerke" xFF(255) oder "CD-ROM- und Wechsellaufwerke" xb5(181), Bleibt also nur die Registry direkt zu ändern.


    2. Ohne automatische Wiedergabe starten:

    Im Explorer auf:
    - "Computer" klicken und im rechten(!) Teilfenster das CD/DVD-Laufwerk mit der rechten Mausstaste anklicken und im Kontextmenü die Aktion:
    "Programme installieren oder ausführen" bzw.
    "Erweiterte Inhalte anzeigen" starten.

    Obwohl der Eintrag als Standardaktion angezeigt wird, kann ein normaler (Doppel-)klick die autorun nicht immer starten. Konnte die Ursache noch nicht ermitteln. Manchmal geht es, bei anderen PCs nicht.

    Hinweis:
    - Im linken Teilfenster kann ebenfalls über das Kontextmenü der gewünschte Eintrag ausgewählt werden.
    - In der Funktionsleiste oben steht: <Organisieren> <Automatische Wiedergabe> <Auswerfen> ...
    Mit "Automatische Wiedergabe" wird die Aktion gestartet, die dort hinterlegt wurde.

    2.1 Mit automatischer Wiedergabe starten:

    Hierzu über die Systemsteuerung den Punkt "Automatische Wiedergabe" aufrufen und Haken setzten bei:
    "Automatische Wiedergabe für alle Medien und Geräte verwenden"

    Alles auf Standard belassen bzw. keinen auswählen. <Speichern> anklicken und DVD einlegen.
    Jetzt sollte sich ein Fenster "Automatische Wiedergabe" öffnen und man kann das Programm, u.a. Aktionen starten.

    2.2 Soll das Programm sofort von DVD starten
    , kann in den Einstellungen von "Automatische Wiedergabe" bei dem entsprechenden Mediumtyp, z.B. "Enhanced Audio-CD" oder "Software und Spiele", der Wert "Erweiterte Inhalte ausführen" bzw. "Programm installieren oder ausführen" als Standard vorgegeben werden. Dann öffnet sich das Programm sofort ohne Nachfragen, was ein Sicherheitsrisiko sein kann.

    Hinweis:
    Gibt es den Wert nicht, ist er über eine Policy, in dem Fall "AutoAusführen-Standardverhalten" deaktivert/entfernt worden. Der Eintrag ist im selben Registryabschnitten zu finden wie oben.
    Der RegWertname dazu: "NoAutorun", Wert: "1" = blendet den Eintrag aus.
    Der Wert "2" aktiviert dagegen das Autoausführen. Fehlt der Eintrag ist das Verhalten wie bei "2".

    3. Der Regkey und Service: " hkey_local_machine\system\current control set\services\cdrom." wird in WIN7 nicht verwendet/ausgewertet soweit ich das getestet habe.

    4. Anbei die Erklärung zu den Registrywerten aus den Gruppenrichtlinien:

    4.1 AutoAusführen-Verhalten (Key: NoAutorun)

    Legt das Standardverhalten für AutoAusführen-Befehle fest.

    AutoAusführen-Befehle werden im Allgemeinen in der Datei "autorun.inf" gespeichert. Sie starten häufig das Installationsprogramm oder andere Routinen.

    Bei Versionen vor Windows Vista wird das Programm automatisch ohne Benutzereingriff ausgeführt, sobald ein Medium eingelegt wird, das einen AutoAusführen-Befehl enthält.

    Dies stellt ein großes Problem für die Sicherheit dar, da Code ohne das Wissen des Benutzers ausgeführt werden kann. Das Standardverhalten von Windows Vista sieht daher vor, den Benutzer zur Bestätigung aufzufordern, ob der AutoAusführen-Befehl ausgeführt werden soll. Der AutoAusführen-Befehl wird im Dialogfeld der automatischen Wiedergabe als Handler dargestellt.

    Wenn Sie diese Richtlinie aktivieren, kann ein Administrator das AutoAusführen-Standardverhalten von Windows Vista wie folgt ändern:

    A) AutoAusführen-Befehle vollständig deaktivieren oder
    B) Zurücksetzen zum Verhalten vor Windows Vista, bei dem der AutoAusführen-Befehl automatisch ausgeführt wird.

    Wenn Sie diese Richtlinie deaktivieren oder nicht konfigurieren, fordert Windows Vista den Benutzer zur Bestätigung auf, ob der AutoAusführen-Befehl ausgeführt werden soll.

    4.2 Autoplay deaktivieren (NoDriveTypeAutoRun)

    Deaktiviert die automatische Wiedergabe.

    Mit diesem Feature werden Datenträger sofort nach dem Einlegen in ein Laufwerk gelesen. Setupdateien von Programmen werden sofort gestartet und Audiomedien sofort wiedergegeben.

    Bei Versionen vor Windows XP SP2 ist die automatische Wiedergabe auf Wechsellaufwerken, z. B. Diskettenlaufwerken (nicht aber CD-ROM-Laufwerken), und auf Netzlaufwerken deaktiviert.

    Seit Windows XP SP2 kann die automatische Wiedergabe auch auf Wechsellaufwerken, einschließlich ZIP-Laufwerken und einigen USB-Massenspeichergeräten, verwendet werden.

    Wenn Sie diese Einstellung aktivieren, kann die automatische Wiedergabe auch auf CD-ROM- und Wechsellaufwerken oder generell auf allen Laufwerken deaktiviert werden.

    Diese Einstellung deaktiviert die automatische Wiedergabe auf weiteren Laufwerktypen. Sie können diese Einstellung nicht zum Aktivieren der automatischen Wiedergabe auf Laufwerken verwenden, auf denen es standardmäßig deaktiviert ist.

    Hinweis: Diese Einstellung wird in den Ordnern "Computerkonfiguration" und "Benutzerkonfiguration" angezeigt. Bei widersprüchlichen Einstellungen haben die Einstellungen unter "Computerkonfiguration" Vorrang vor den Einstellungen unter "Benutzerkonfiguration".
     
Thema: autorun geht nicht
Besucher kamen mit folgenden Suchen
  1. dvd autostart windows 7 aktivieren

    ,
  2. WIN7 usb autostart aktivieren

    ,
  3. autorun inf windows 7 aktivieren

    ,
  4. windows 7 autostart für dvd aktivieren,
  5. cd rom autostart aktivieren windows 7,
  6. autostart dvd aktivieren windows 7,
  7. windows 7 dvd autostart aktivieren,
  8. win7 dvd autostart aktivieren,
  9. autoplay funktioniert nicht,
  10. usb autorun aktivieren windows 7,
  11. win7 cd autostart aktivieren,
  12. usb inf windows autostart,
  13. autoplay windows 7 aktivieren,
  14. dvd autostart erstellen win7,
  15. autorun für usb stick in win7 aktivieren,
  16. autostart cd windows 7 aktivieren,
  17. autorun usb stick aktivieren,
  18. autorun.inf für festplatte aktivieren,
  19. win7 cd autorun aktivieren,
  20. win 7 usb autostart aktivieren,
  21. autorun funktioniert nicht windows 7,
  22. autostart usb stick aktivieren windows 7,
  23. usb autostart aktivieren,
  24. dvd autorun aktivieren Win7,
  25. autorun für usb stick in win 7 aktivieren
Die Seite wird geladen...

autorun geht nicht - Ähnliche Themen

  1. Xystec Universal-Festplatten-Adapter für IDE/SATA auf USB 3.0 geht nicht mehr

    Xystec Universal-Festplatten-Adapter für IDE/SATA auf USB 3.0 geht nicht mehr: Guten Abend zusammen beieinander, anläßlich der Entsorgung meines alten PC waren zwei Festplatten mit (lächerlichen) 200 GB und 250 GB...
  2. Wie weit geht Microsofts Spionage? Was ist erlaubt - was ist verboten

    Wie weit geht Microsofts Spionage? Was ist erlaubt - was ist verboten: So werden wir von Microsoft ausspioniert. Gefunden unter appdata\local\temp: dd_vcredistMSI7B31.txt I (s) (E8:E4) [19:01:39:417]: SOFTWARE...
  3. Wlan geht nicht

    Wlan geht nicht: Guten Tag, ich habe meinen alten Laptop Medion MD96630 von Vista auf W 7 Ultimate umgestellt. Leider funktioniert Wlan nicht. Kann dieser PC das...
  4. Systemreperatur geht nicht mehr weg

    Systemreperatur geht nicht mehr weg: Das erscheint nach den start und ich komme da nicht mehr weg. Und irgendwann nach 20min steht da fertigstellen ich klicke drauf es startet neu und...
  5. Die Stunden-Win7-Systemuhr geht nach Korrektur immer wieder nach.

    Die Stunden-Win7-Systemuhr geht nach Korrektur immer wieder nach.: Ich muss ständig die Stunde der Win7-Systemuhr korrigieren. Sie geht immer nach. Die Minuten bleiben immer stimmig. Ich vermute einen Zusammenhang...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden